Results 1 to 6 of 6

Thread: Mk2 GTE Stalling?

  
  1. #1
    Status
    Offline
    alisk's Avatar
    AOC Newbie
    Join Date
    Aug 2003
    Posts
    27
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Mk2 GTE Stalling?

    Hi there

    My 1989 Astra GTE 16v doesn't seem to be running right at idle - keeps stalling or nearly-stalling, but only at intervals. Any ideas please?

    Car was only serviced recently, and for the most is OK, but occasionally goes through little periods of not running at idle.

    Cheers

  2. #2
    Status
    Offline
    VIPER's Avatar
    AOC Newbie
    Join Date
    Jun 2003
    Posts
    68
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Try cleaning out the idle control valve with some carb cleaner, Over time these get crudded up and cause idle problems and stalling...........
    Drives - 97 Vectra SRI 2.5 V6 24v

  3. #3
    Status
    Offline
    Nrj's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    4,807
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    On the red top engine it's under the SFI box, good luck :?

    If you get stuck Autosparks has just done it PM him, pretty sure the alternator has to come off if you do it from the top.
    Cant Think of Anything Funny To Say

  4. #4
    Status
    Offline
    ineson's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    1,169
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had to do this recently but couldnt do it myself as it was in a bugger of a place to get to. Took it to my local autoclinic and he gave me a valve cleaning additive that you add to your petrol tank and it runs through the engine cleaning all the valves including ICV. It is called FORTE.

    Put it in about 3 weeks ago now and its been running really well ever since.

    Highly reccomend it to anyone.
    Calibra 2.0 8v

  5. #5
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Yep I have cleaned mine recently on a 2.0 engine.

    Not to bad to get at from the top as long as you take the 2 pipes it connects to of aswell rather that struggle. Hardest big was undoing the connector on it.

    Pm me if you need any more help
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  6. #6
    Status
    Offline
    alisk's Avatar
    AOC Newbie
    Join Date
    Aug 2003
    Posts
    27
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thanks guys. Looks like a long oily night ahead then...... :roll:

    Will get back to you if it goes tits up!!!

Similar Threads

  1. v6 van keeps stalling
    By c20letmatt in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 0
    Last Post: 19-04-2009, 20:55
  2. Stalling
    By GSISWIV in forum Turbo Petrol Engines inc. Transmissions
    Replies: 5
    Last Post: 09-07-2008, 22:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •